SmartUse for Android

Compatible with Android smartphones and tablets

  • Works on tablets like the Samsung Galaxy, Asus Zen Pad and more
  • Works on smartphones like the Google Pixel, Samsung Galaxy and more
  • Requires Android 5.0 or later